Browse Source

Install requirements with pip instead with setup

Óscar García Amor 4 years ago
parent
commit
65b6a7b6cb
5 changed files with 5 additions and 12 deletions
  1. 1 0
      README.md
  2. 2 1
      requirements.txt
  3. 0 5
      setup.py
  4. 0 4
      sysdweb/templates/static/css/sysdweb.css
  5. 2 2
      sysdweb/templates/views/journal.tpl

+ 1 - 0
README.md

@@ -8,6 +8,7 @@ git clone https://github.com/ogarcia/sysdweb.git
 virtualenv3 ./sysdweb-venv
 source ./sysdweb-venv/bin/activate
 cd sysdweb
+pip install -r requirements.txt
 python setup.py install
 ```
 

+ 2 - 1
requirements.txt

@@ -1,2 +1,3 @@
 bottle >= 0.12.10
-dbus-python >= 1.2.4
+dbus-python
+systemd-python

+ 0 - 5
setup.py

@@ -40,11 +40,6 @@ setup(
             'sysdweb = sysdweb.main:main'
         ]
     },
-    install_requires = [
-        "bottle>=0.12.10",
-        "dbus-python>=1.2.4",
-        "systemd-python"
-    ],
     classifiers=[
         "Development Status :: 3 - Alpha",
         "Topic :: Utilities",

+ 0 - 4
sysdweb/templates/static/css/sysdweb.css

@@ -18,10 +18,6 @@ a:hover {
   margin-bottom: 0
 }
 
-pre {
-  margin-bottom: 0
-}
-
 .table > tbody > tr > td {
   vertical-align: middle;
 }

+ 2 - 2
sysdweb/templates/views/journal.tpl

@@ -30,11 +30,11 @@
         <small>{{hostname or 'sysdweb'}}</small></h1>
       </div>
       <div>
-        <pre id="journal">
+<pre id="journal">
 % for line in journal:
 {{line}}
 % end
-        </pre>
+</pre>
       </div>
     </div>
   </body>